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his online guide contains all the information you need to use the 
Acrobat Reader program. For installation instructions, system 
requirements, and registration information, see the Getting Started 
Card accompanying your software. 



HOW TO USE THIS ONLINE GUIDE
Click underlined text to jump to a related topic. Underlined text 
indicates text that is “linked” to another part of the guide.

Click the Go Back button to retrace your steps and return to a 
previous location (for example, after reading a linked topic).

Click the Next Page button to go to the next page of the guide.

Click the First Page button to return to the opening screen (and 
main menu) of this guide. 

Double-click the page icon to the left of a bookmark name to 
jump to the topic marked by that bookmark. Click the triangle 
to the left of a bookmark to show and hide subtopic bookmarks. 

Click the arrow button to jump to the next screen of a continued 
topic.

See Browsing through documents

 

 for more information on how 
to page through Acrobat documents.

See 

 

Mouse, menu, and window basics

 

 for instructions on how 
to choose commands and perform other basic tasks.
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ABOUT ADOBE ACROBAT SOFTWARE
The Acrobat Reader program is part of the Adobe Acrobat family of soft-
ware. Acrobat software lets you create, view, and print documents in the 
Portable Document Format (PDF)—regardless of the computer, operating 
system, fonts, or application used to create the original documents. PDF 
files retain all the formatting, fonts, and graphics of the original documents, 
and virtually any document can be converted into a PDF file.

You can use the Acrobat Reader program to view, search, and print docu-
ments that have been converted to the Portable Document Format. You can 
also use the Reader program to view and print notes attached to PDF files.

PDF documents can contain: link buttons

 

, which you use to jump to related 
information; 

 

bookmarks

 

, which can be used as an electronic table of con-
tents; and 

 

electronic notes

 

. The 

 

Acrobat Exchange program

 

 can be used to 
add link buttons, bookmarks, and electronic notes to a PDF document.

See the following topics for more information about Acrobat software:

 

About the Portable Document Format (PDF)

The Acrobat Exchange program (and PDF Writer)

How the Exchange and Reader programs display and print fonts

Acrobat Distiller

 





ABOUT THE PORTABLE DOCUMENT FORMAT 
(PDF)
The Portable Document Format is a document description language that 
forms the basis of the Acrobat family of electronic document products. 
Although PDF files retain all of the fonts, formatting, graphics, and color 
of the documents they represent, they usually require much less storage 
than the original document files. And no matter which application or com-
bination of applications is used to create a document, the PDF file created 
for the document can be viewed and printed by anybody with either the 
Acrobat Exchange

 

 or Reader program.

The 

 

Acrobat Distiller

 

 program converts PostScript language descriptions of 
documents into PDF files. The Acrobat 

 

PDF Writer

 

 drivers, included with 
the Acrobat Exchange programs, create PDF files directly from within 
Windows and Macintosh applications.

Because all of the characters used in a PDF file are 7-bit, printable ASCII 
characters, PDF files can easily be transferred between different kinds of 
computers with virtually any kind of file transfer, modem, or network 
software.



In addition to preserving the original look and feel of a document, a PDF file 
can also contain: link buttons

 

, which link related information; 

 

bookmarks

 

, 
which provide a scrollable list of marked document locations; 

 

thumbnail

 

 
images of document pages, which can be used to quickly locate and move to 
pages of interest; and 

 

electronic notes

 

. 

PDF files can combine pages from two or more source documents and can 
contain pages of virtually any size and orientation. Portrait and oversized 
landscape pages, for example, can be combined in the same PDF file. The 
pages of a PDF document can also be cropped to remove white space for 
onscreen viewing.

Based on the PostScript

 



 

 page description language, PDF is an open 
standard that is fully described in the 

 

Portable Document Format Reference 
Manual

 

, published by Addison-Wesley.



THE ACROBAT EXCHANGE PROGRAM
Like the Acrobat Reader program, the Acrobat Exchange program lets 
you view, search, and print PDF documents. In addition, you can use the 
Exchange program to add links

 

, 

 

thumbnails

 

, 

 

bookmarks

 

, and 

 

notes

 

 to PDF 
files. You can also use the Exchange program to remove pages from PDF 
files, to combine pages from two or more PDF files, and to crop white space 
from pages to improve on-screen viewing.

 

PDF Writer

 

The Acrobat Exchange program package includes the PDF Writer driver, 
which lets you create PDF files from any application by “printing” to a 
file. PDF Writer can be used successfully to create PDF files for most docu-
ments; however, to create PDF files for documents that contain Encapsulated 
PostScript (EPS) artwork or 24-bit color images, or for documents that 
use features available only with PostScript printers (such as blends), the 

 

Acrobat Distiller

 

 produces the best results.



HOW THE EXCHANGE AND READER 
PROGRAMS DISPLAY AND PRINT FONTS
When the fonts used to create a document are installed on your system, 
the Exchange and Reader programs use those fonts to display and print 
the PDF file for that document. When you do not have the fonts used to 
create a document, the Exchange and Reader programs use Adobe multiple 
master fonts installed with the programs to create look-alike substitute 
fonts. These substitute fonts are not exact duplicates of the original fonts, 
but they are very close. See About fonts

 

 and 

 

Choosing preferences

 

 for more 
information about substitute fonts.

 

Note:

 

 If you open a PDF document and the fonts are incorrectly displayed 
in Courier, the document may have been created using the 

 

Acrobat Distiller

 

 

 

program

 

 without access to the original fonts. In the U.S., call the Acrobat 
Fax Request Line at 408-986-6560 to request a technical note that describes 
in detail how the Distiller program handles different kinds of fonts.



THE ACROBAT DISTILLER  PROGRAM
The Acrobat Distiller program creates PDF files from any document that has 
first been saved as a PostScript language file. While PDF files can also be 
created using the PDF Writer included with the Exchange program

 

, Acrobat 
Distiller is recommended for high-quality reproduction of Encapsulated 
PostScript (EPS) artwork, 24-bit images, and documents that take advantage 
of features available only on PostScript printers (such as blends). By down-
sampling color and grayscale images, the Distiller program can also create 
smaller PDF files than those created using PDF Writer.

Two versions of the Distiller program are available: the Personal Distiller 
and the Network Distiller.

To use the Personal Distiller program, you start the program and open the 
PostScript file created for a document; the Personal Distiller then reads 
the PostScript file and creates a PDF file in the location you specify.

The Network Distiller program provides distilling services for network 
users. Users create PostScript files for their documents and copy the 
PostScript files to the Network Distiller’s In directory. The Network 
Distiller automatically finds the PostScript files in the In directory, reads 
the files, and creates PDF files in its Out directory.



THE ACROBAT READER WINDOW
When you open a PDF file with the Acrobat Reader program, the document 
appears in the window. Depending on how the PDF file has been set up, 
you can display bookmarks or thumbnails in an overview area to the left 
of the document. (See Using bookmarks

 

 and 

 

Using thumbnails

 

 for more 
information.)

Beneath the menu bar at the top of the window is the tool bar; at the bottom 
left of the window is the status bar. Use the vertical scroll bar at the right of 
the window to 

 

scroll

 

 up and down through a document. The overview area 
of the window, which is opened with the 

 

Bookmarks and Page

 

 and 

 

Thumb-
nails and Page

 

 buttons, includes an independent scroll bar that you can use 
to scroll through bookmarks or thumbnails. 

See these topics for more information about the Acrobat Reader window:

 

Mouse, menu, and window basics Status bar fields and controls

Window areas, menus, and tool bar Tools and buttons

Browsing through documents Menu commands

Magnifying the page view



MOUSE, MENU, AND WINDOW BASICS
The DOS version of the Acrobat Reader program closely resembles the 
Microsoft  Windows  version of the Reader program. If you are familiar 
with standard Windows operations, you do not need to read the topics listed 
below. If you are unfamiliar with standard Windows operations, however, 
read the following topics to learn how to choose commands, make selec-
tions in dialog boxes, and scroll through the contents of the document and 
overview areas within the Reader window.

See the following topics for instructions on basic operations:

Using the mouse: clicking, double-clicking, and dragging

Window areas, menus, and the tool bar

Choosing commands from menus

Using dialog boxes

Using scroll bars



USING THE MOUSE: CLICKING, DOUBLE-
CLICKING, AND DRAGGING
You use the mouse to choose commands from menus, to press buttons on 
the tool bar, to select options in a dialog box, and to control many other 
aspects of the Reader program. Basic mouse operations include clicking, 
double-clicking, and dragging.

Clicking

To select a command, option, or other object, move the mouse pointer over 
the object and press the left button. Pressing and releasing the left mouse 
button once is called clicking. (You do not use the right mouse button with 
the Reader program.)



Double-clicking

Quickly pressing and releasing the left mouse button twice is called double-
clicking. You can open a PDF document in the Open dialog box by double-
clicking the document name. Similarly, you can open a directory in the 
Open dialog box by double-clicking the directory’s name.

Dragging

Holding down the left mouse button while you move the mouse pointer is 
called dragging. You drag the mouse to select and move an object (such as 
a note) from one place to another. You also drag the mouse to magnify or 
reduce your view of a specific part of a page. To magnify part of a page, for 
example, first click the zoom-in tool and then drag to draw a box around the 
part of the page you want to magnify. When you release the mouse button, 
the page view expands to fill the box you drew.



WINDOW AREAS, MENUS, AND THE TOOL BAR

 

Quit box
(double-click to quit

Reader program)

 

Close box
(click to close

document)

 

Overview area
(shows bookmarks

or thumbnails)

 

Document area
(shows document
pages)

 

Tool
(click
to use)

 

Splitter
(drag to 
adjust area
sizes)

 

Page box
(click to
jump to 
page)

 

Magnification box
(click to
change
magnification)

 

Scroll bar
(use to scroll
contents of window)

 

Command
(click to
choose)

 

Menu bar

 

Tool bar

 

Menu
(click to show
commands)



CHOOSING COMMANDS FROM MENUS
To choose a menu command, click

 

 the name of the menu that contains the 
command; the menu’s list of commands is displayed. Then click the name 
of the command.

 

Keyboard shortcuts

 

Some commands can be chosen using a keyboard shortcut, which is a com-
bination of two or more keys that you press together to choose a command 
without opening its menu. Keyboard shortcuts are shown to the right of 
command names in menus.

 

Choosing commands without using the mouse

 

You can open menus and select commands without using the mouse. To 
open a menu, press the Alt key and the underlined letter in the menu name. 
Press Alt+F, for example, to open the File menu. After a menu is open, 
you can select a command by pressing the underlined letter in the command 
name. With the File menu open, for example, press O to choose the Open 
command.



Dialog boxes

When you choose a command that is followed by ellipses (. . .), a dialog box 
appears. Dialog boxes let you select related options or view related infor-
mation. The Print dialog box, for example, lets you select a range of pages 
to print. See Using dialog boxes

 

 for information about selecting options in 
a dialog box.



USING DIALOG BOXES
Choosing a command that is followed by ellipses (. . .) displays a dialog 
box. The dialog box remains displayed until you click a command button.

Command buttons

Command buttons perform actions. Click

 

 a command button to 
perform the action it represents. Two common command but-
tons are OK and Cancel. OK tells the Reader program to accept 
the settings currently shown in the dialog box (and to close the 
dialog box). Cancel tells the Reader program to close the dialog 
box without making changes. A command button with a thick 
black outline can be selected by pressing the Enter key.

 

Option buttons

 

Option buttons indicate a group of options from which only one 
option can be selected at a time. Click an option button to select 
the option it represents. A black dot in the center of a button 
indicates the selected option.

Yes

No

Cancel

All


Range



Check boxes

Check boxes represent options that can be selected indepen-
dently of other options. Click a check box to select the option it 
represents. An X in the box indicates that an option is selected. 
Click a selected check box to clear the box and deselect the 
option.

Text boxes

Text boxes let you enter numbers or names. When you click in 
a text box, the mouse pointer changes to an I-beam and a text 
insertion cursor [ | ] appears in the box. Characters you type 
are inserted in front of the cursor. You can replace one or more 
characters in a text box by dragging

 

 the I-beam through the 
characters to highlight them and typing the replacement charac-
ters. When one or more characters are highlighted, typing a 
character replaces the highlighted characters with the new 
character.

Print to File

Shrink to Fit

Filename

Filename

DOC1.PDF



List boxes

List boxes display lists of options. When a list con-
tains more options than can be displayed in the list 
box, scroll bars

 

 appear to the right of the list box. 
Use the scroll bar to see all the options in the list. 
Click an option in a list box to select it. Selected list 
options are highlighted.

See 

 

Opening documents

 

 for a description of controls 
unique to the Open dialog box.

DOC1.PDF

DOC2.PDF

DOC3.PDF

HELPREAD.PDF

MAP.PDF

MEMO1.PDF

MEMO2.PDF

PHONE.PDF



USING SCROLL BARS
To use a scroll bar, either place the mouse pointer 
over the arrow that points in the direction you want 
to scroll and hold down the left mouse button, or 
drag

 

 the scroll box in the direction you want to 
scroll.

The 

 

document and overview areas

 

 in the Reader 
window contain vertical and horizontal scroll bars.

When a document page is wider than the document area, use the horizontal 
scroll bar to scroll the document view left and right.

Use the vertical scroll bar to the right of the document area to scroll up and 
down a page, and to scroll from one page to the next. Drag the scroll box in 
the vertical scroll bar to jump directly to another page.

Use the vertical scroll bar to the right of the overview area to scroll through 
the list of bookmark names when 

 

bookmarks

 

 are shown, or to scroll through 
the thumbnail images of document pages when

 

 thumbnails

 

 are shown. Use 
the horizontal scroll bar beneath the overview area to scroll left or right to 
see long bookmark names.

MEMO2.PDF

PHONE.PDF

POSTRATE.PDF

TOURREAD.PDF

SCHED1.PDF

SCHED2.PDF

STOCKS.PDF

ZIPCODES.PDF



TOOLS AND BUTTONS
The tool bar contains tools for navigating, searching, and viewing docu-
ments. Click a tool icon to select the tool it represents. 

To hide or show the tool bar, choose Hide Tool Bar or Show Tool Bar from 
the Window menu. The command alternates between the two options.

The tool bar contains the following tools and buttons:

Click the Page Only button to close the overview area

 

 of the 
window.

Click the 

 

Bookmarks and Page button

 

 to open the overview area 
and display bookmarks created for the document. Double-click the 
page icon to the left of a bookmark name to jump to the location 
marked by that bookmark. See 

 

Using bookmarks

 

 for details.

Click the 

 

Thumbnails and Page button

 

 to open the overview 
area and display thumbnail images of each document page. Click 
a thumbnail to jump to the page marked by that thumbnail. See 

 

Using thumbnails

 

 for details.



Use the hand tool to scroll over a page when the 
whole page does not fit within the document area of 
the window. Hold down the mouse button and drag 
the hand tool in the direction you want to move the 
page.

Use the zoom tools to magnify and reduce 
your view of document pages. See Magnifying the 
page view

 

 for details.

Use the 

 

browse buttons

 

 to move to the first or last 
page of a document, or to move forward or back one 
page at a time. See 

 

Browsing through documents

 

 for 
details.

Use the

 

 navigation buttons

 

 to retrace your steps 
through a document, moving backward or forward 
to each view in the order visited. See 

 

Browsing 
through documents

 

 for details.



Click the Actual Size button to display the page at 100 percent.

Click the Fit Page to Window button to scale the page so that the 
whole page is visible within the document area of the Reader window.

Click the Fit Width to Window button to scale the page so that the 
width of the page fills the document area within the Reader window.

Use the find tool to search for a word or part of a word in a document. 
See Searching for words

 

 for details.



STATUS BAR FIELDS AND CONTROLS
The status bar contains the following fields and controls:

Use the window splitter to adjust the width of the overview 
and document areas. Hold down the mouse button and drag the 
control to where you want to divide the two areas. Increasing 
the size of the overview area for bookmarks shows longer 
bookmark names. Increasing the size of the overview area for 
thumbnails shows more columns of thumbnails.

The page number box displays the current page number and 
lets you jump to a specified page in a multi-page document. 
Click the page number box to display the Go to Page dialog box, 
then enter the page number you want, and click OK.

Note: The page numbers used by the Reader program begin 
with page 1 for the first page of a document and continue 
sequentially through the last page of the document. For this 
reason, the Reader page numbers may not match the page 
numbers you see on document pages.
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The magnification box displays the current page magnification 
and lets you change the magnification. Click the magnification 
box to display the Zoom To dialog box. See Magnifying the 
page view

 

 for details.

400 %



PROCEDURES
Click a topic name to jump to that topic:

Mouse, menu, and window 
basics

Opening documents

Magnifying the page view

Browsing through documents

Using thumbnails

Using bookmarks

Setting up a printer

Printing documents

 

Choosing preferences

Searching for words

Using notes

Using links

Displaying information 
about a document

Installing fonts

Keyboard shortcuts



OPENING DOCUMENTS
You open documents by using the Open File dialog box. Choose Open 
from the File menu (or press Ctrl+O) to display the Open File dialog box.

Note: The DOS version of the Acrobat Reader program can open only one 
document at a time. Opening a new document closes the current document.

DOC1.PDF

DOC2.PDF

DOC3.PDF

HELPREAD.PDF

MAPLOC1.PDF

MAPLOC2.PDF

MAPLOC3.PDF

MEMO1.PDF

MEMO2.PDF

PHONALL.PDF

PHONLOC1.PDF

PHONLOC2.PDF

PHONLOC3.PDF

POSTRATE.PDF

TOURREAD.PDF

Filename

*.PDF

A:

B:

C:

C:\

  ACRODOS

C: \ACRODOS\

Display file types

PDF Files    (*.PDF)


All Files       (*.*)

Open Cancel

Open File

Drive



To open a document:

1 In the Drive list, double-click

 

 the letter of the drive containing the 
document you want to open. The directories at the root level of the drive you 
select are shown in the Directory list. You can also select a drive by clicking 
a drive letter and pressing Enter. 

 

2

 

Use the Directory list to open the directory containing the document. To 
open a directory, double-click the name of the directory in the Directory list. 
The name of the current directory is shown above the Directory list, and the 
file list shows the files in the current directory. You might have to 

 

scroll

 

 
through the Directory list to see the directory you want. You can also open a 
directory by clicking a directory name and pressing Enter. To quickly navi-
gate a long directory list, select any directory and type a letter. The directory 
list scrolls to the first directory name beginning with that letter. To move back 
up the directory tree, double-click the name of a higher-level directory or 
drive letter.



3 In the file list, double-click the name of the document you want to open. 
The Open dialog box closes and the first page of the document appears. You 
can also open a document by clicking first its name, then Open. To quickly 
navigate a long file list, select any file and type a letter; the file list scrolls to 
the first filename beginning with that letter.

By default, only files with filenames that end with .PDF are shown in the 
file list. To see all the files in the current directory, click the All Files option 
button.

Opening a document by entering its full pathname

If you know the full pathname of the document you want to open, you can 
open the file by entering the full pathname in the Filename text box

 

 and 
clicking Open.

 

Opening one of the last four documents opened

 

The File menu lists filenames of the last four PDF documents that you have 
opened. To open one of these documents, choose the filename you want 
from the File menu.



MAGNIFYING THE PAGE VIEW
You can use the zoom tools, the magnification box in the status bar, or the page 
view buttons in the tool bar to change the magnification of your page view.

To use the zoom tools:

• Click using the zoom-in tool (+) to magnify the document 
by a factor of 2. Click using the zoom-out tool (–) to reduce the 
magnification by a factor of 2.

• To magnify or reduce a selected area, select a zoom tool and drag

 

 
the mouse to draw a rectangle around the area you want to view.

 

•

 

With the zoom-in tool, the page view expands to show just the 
contents of the rectangle. With the zoom-out tool, the current 
page view reduces to fit within the rectangle.

This is sample text. This is 
sample text. This is sample 
text. This is sample text. 
This is sample text. This is 
sample text. This is sample 
text. This is sample text. 
This is sample text. This is 
sample text. This is sample 
text. This is sample text. 
This is sample text. This is 

sample text. This is sample 
text. This is sample text. 

This is sample text. This is 
sample text. This is sample 
text. This is sample text. 
This is sample text. This is 
sample text. This is sample 
text. This is sample text. 
This is sample text. This is 
sample text. This is sample 

SAMPLE HEADLINE This is sample text. This is 
sample text. This is sample 
text. This is sample text. 
This is sample text. This is 
sample text. This is sample 
text. This is sample text.



• To toggle between the zoom-in and zoom-out tools, hold down the 
Control key.

To use the magnification box:

Click the magnification box to display the Zoom To dialog 
box; then enter the percent of magnification or reduction you 
want and click OK.

To use the page view buttons

Click the Actual Size button to display the page at 100 percent.

Click the Fit Page to Window button to scale the page so that the 
whole page is visible within the document area of the Reader window.

Click the Fit Width to Window button to scale the page so that the 
width of the page fills the document area of the Reader window.

400 %



BROWSING THROUGH DOCUMENTS
The Acrobat Reader program provides a number of ways to browse through 
a document:

To page through a document:

Click the Previous Page or Next Page button to move back or 
forward one page. You can also use the Previous Page and Next 
Page commands in the View menu or the Left Arrow (or Up 
Arrow) and Right Arrow (or Down Arrow) keys on your key-
board.

Use the PageUp or PageDown key on the keyboard to move for-
ward or back one screenfull at a time. You can also press Return 
and Shift+Return to move forward and backward one screenfull 
at a time.



To jump to a specified page:

Use the vertical scroll bar to scroll forward and back through a 
document. As you drag the scroll box, a box to the left of the 
scroll bar displays the current page number. Click above or 
beneath the scroll box to move back or forward one screenfull.

Click the First Page or Last Page button to move to the first or 
last page of a document. You can also use the First Page and 
Last Page commands in the View menu or the Home and End 
keys on the keyboard. 

Click the page number box in the status bar at the bottom of the 
main window or choose Go to Page from the View menu to 
display the Go to Page dialog box; then enter the page number 
you want and click OK.

Note: You can also use thumbnails and bookmarks in the overview area to 
jump to specified pages. See Using thumbnails

 

 and 

 

Using bookmarks

 

 for 
more information.

Page 17
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To retrace your steps in a document:

Click the Go Back and Go Forward buttons to retrace your steps 
through a document, one view at a time. You can also use the 
Go Back and Go Forward commands in the View menu.

Go Back returns you to your previous page view. Your previous 
page view might be the previous page or screen, or it might be 
a reduced or magnified view of the current page. Your previous 
page view might also be the page view before scrolling around 
the current page.

Go Back is very useful for recovering from navigational mis-
takes. If you zoom in or out by mistake, or if you jump to the 
wrong page, click Go Back to return to your previous view.

Go Forward reverses direction and returns you, one view at a 
time, to the view where you first used Go Back.

You can use the Go Back feature to retrace your steps through 
100 views.

See Using thumbnails

 

 and 

 

Using bookmarks

 

 for other ways of browsing 
through a document.



USING THUMBNAILS
You can use thumbnails to jump quickly to a page, and to adjust the 
view of the current page. Thumbnails may be created when the PDF file is 
created using the Acrobat Distiller program

 

, or they may be added to a 
document using the 

 

Acrobat Exchange program

 

.

 

To browse using thumbnails: 

 

Click the Thumbnails and Page button or choose Thumbnails and 
Page from the View menu to display thumbnail images in the over-
view area. If you don’t see thumbnails in the overview area, the doc-
ument was created without them. Click a thumbnail to move to that 
page. The spot you click determines the center of the page display.



To see two or more columns of thumbnails in the overview area, drag the 
window splitter

 

 to the right.

 

Using thumbnails to scroll and change magnification

 

The light gray box on the thumbnail, called the page-view box, indicates the 
part of the page visible in the document area of the Reader window. You can 
use the page-view box to scroll around a page and to change the magnification. 

 

To scroll and change magnification:

 

•

 

Drag the page-view box on the thumbnail to scroll around the current page.

 

•

 

Drag the lower right corner of the page-view box in or out to reduce or 
expand the view of the current page.

 

•

 

To redraw the page-view box, position the pointer anywhere outside the 
current page-view box and drag to draw a box around the area of the page you 
want to view. 
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USING BOOKMARKS
You can use bookmarks to jump quickly to a marked view of a page. 
Bookmarks may be added to a PDF document using the Acrobat Exchange

 

 

 

program

 

.

Click the Bookmarks and Page button or choose Bookmarks and 
Page from the View menu to display bookmarks in the overview area. 
If you don’t see bookmarks in the overview area, the document was 
created without them. Double-click the page icon to the left of a 
bookmark name to move to the view specified by that bookmark.

Click the triangle to the left of a bookmark name to show and hide any 
subordinate bookmarks.

To see long bookmark names, drag the 

 

window splitter

 

 to the right.



SETTING UP A PRINTER
Before you can print, you must use the Printer Setup dialog box to tell the 
Reader program the kind of printer you have and the port to which the 
printer is attached. If your computer is connected to more than one printer, 
you can also use the Printer Setup dialog box to change printers.

To set up the Reader program to work with a printer:

1 Choose Print Setup from the File menu. The Printer Setup dialog box 
appears.

2 If you are using a PostScript printer, click the PostScript option button

 

. 
Otherwise, click the Bitmap option button. (Click the Bitmap option for 
LaserJet

 



 

 printers running in the PCL

 



 

 mode and other PCL printers.)

 

3

 

If you selected Bitmap, click the model name of the printer you are using 
in the printer list. You might have to 

 

scroll

 

 through the printer list to see the 
model name you want. See 

 

Using an unlisted printer

 

 for instructions if you 
don’t see the model name of your non-PostScript printer.



4 In the Port list, click the name of the port to which the printer is connected. 
If you are using a network printer, click the name of the port being used for 
the network printer. Ask your network administrator if you do not know 
which port is being used for a network printer. Also, either you or your 
network administrator should read the Timeout requirements for network 
printers

 

 topic if you are using a network printer.

 

5

 

Click OK.



PRINTING DOCUMENTS
Before you can print, you must set up the Reader program to work with 
your printer. See Setting up a printer

 

 for instructions. 

 

To print a document:

 

1

 

Choose Print from the File menu. The Print dialog box appears.

 

2

 

By default, all the pages in a document are selected. If you do not want to 
print the whole document, enter the page numbers of the first and last pages 
you want in the page range 

 

text boxes

 

. Entering a page number automatically 
selects the Range option button.

 

Note:

 

 The page numbers used by the Reader program begin with page 1 for 
the first page of a document and continue sequentially through the last page 
of the document. For this reason, the Reader page numbers may not match 
the page numbers you see on document pages.

 

3

 

Choose the print options you want. The print options are described below.

 

4

 

Click OK. The Print dialog box closes and the document prints.



Quality (non-PostScript printers only)

Select the print quality you want by clicking the Best, Medium, or Draft 
option button. The print quality option determines the resolution, in dots 
per inch, of the printed pages. The resolutions specified by the quality 
options vary with printer type, but Best always produces the highest quality 
pages and takes the longest to print. Draft produces the poorest quality 
pages, but prints the fastest.

PostScript Level 2 (PostScript printers only)

If you are using a printer that supports PostScript Level 2, selecting the 
Level 2 option speeds printing.

Print to File

Select the Print to File option to tell the Reader program to create a disk file 
with printer instructions for the document instead of sending those instruc-
tions to the printer. See Printing to a file

 

 for instructions on how to save a 
print job as a disk file.

 

Shrink to Fit

 

Select the Shrink to Fit option to shrink (and if necessary rotate) oversized 
pages to fit on the paper size currently installed in your printer.



PRINTING TO A FILE
You can print a document to a disk file and later print the document by 
copying the disk file to a printer port. When you print to a file, however, 
remember that the disk file can be used only with the kind of printer 
selected when the file is created.

To print to a file:

1 Choose Print from the File menu. The Print dialog box appears.

2 Click the Print to File check box.

3 Select any print options you want. See Printing documents

 

 for descriptions 
of the print options.

 

4

 

Click OK. The Print to File dialog box appears.

 

5

 

In the Drive list, 

 

double-click

 

 the drive letter of the drive where you want 
to save the new file. The directories at the root level of the drive you select 
are shown in the Directory list.



6 Use the Directory list to open the directory in which you want to save the 
print file. To open a directory, double-click the name of the directory in the 
Directory list. The name of the current directory is shown above the Directory 
list and the file list shows the files in the current directory. You might have 
to scroll

 

 through the Directory list to see the directory you want. You can also 
open a directory by clicking a directory name and pressing Enter. To quickly 
navigate a long Directory list, select any directory and type a letter. The 
Directory list scrolls to the first directory name beginning with that letter. To 
move back up the directory tree, double-click the name of a higher-level 
directory or the drive letter.

 

7

 

Enter a filename for the print file in the Filename text box. By convention, 
PostScript files end with the .PS extension and PCL files end with .PCL.

 

Note:

 

 As an alternative to selecting the destination drive in the Drives list 
and the destination directory in the Directory list, you can enter a full 
pathname for the print file in the Filename text box. When you enter a full 
pathname in the Filename box, the Reader program ignores the current 
selections in the Drive and Directory lists.

 

8

 

Click Print To. The print file is created, and the Print to File dialog box 
closes.



CHOOSING PREFERENCES
The Preferences command in the Edit menu displays a dialog box that 
you can use to change the way the Reader program displays and prints 
documents. The preferences you select affect all the Acrobat documents 
you view.

Changes in some preferences take effect immediately when you click OK. 
But for most preferences, you must restart the Reader program before 
changes in preference settings take effect.

Default Magnification: Enter the initial magnification or reduction 
percentage that you want the Reader program to use when documents are 
opened.

Display Large Images: Select this option to display large images. Clear 
the option to display large images as gray boxes. Displaying large images 
as gray boxes speeds page display.

Note: A “large” image is an image that requires many bytes of storage 
and that requires a long time to display. For example, a small but detailed 
photograph with many colors may require a great deal of storage and thus 
be considered a large image.



Greek Text below __ pixels: Select this option to adjust the size of char-
acters below which the Reader program “greeks” text. Greeked text is 
displayed as a gray line. You specify this setting in pixels to account for 
different levels of magnification. A pixel is a dot on your screen. Increasing 
the default value of this setting can speed page display.

Show splash screen: This option lets you control whether the Reader 
program displays the product information screen when it starts. Deselecting 
this option reduces the time it takes the program to start.

Substitute Fonts: This setting controls which multiple master fonts the 
Reader program substitutes for Type 1 and TrueType fonts that are not 
available on your system. The setting affects the way PDF documents are 
displayed and printed.



By default, the Reader program uses the AdobeSerifMM multiple master 
font for missing serif fonts, and the AdobeSansXMM multiple master font 
for missing sans serif fonts. If PDF documents fail to print because of 
insufficient printer memory, you can reduce the amount of printer memory 
required to print by selecting either Sans Only or Serif Only. Sans Only tells 
the Reader program to use AdobeSansXMM for missing sans serif and serif 
fonts. Serif Only tells the Reader program to use AdobeSerifMM for 
missing sans serif and serif fonts. 

AdobeSansXMM uses less printer memory than AdobeSerifMM; 
AdobeSerifMM is a better substitute for very thin, bold, narrow, or 
extended fonts.

When you change the Substitute Fonts setting, the change does not take 
effect until you restart the Reader program.

See How the Exchange and Reader programs display and print fonts

 

 for 
more information about font substitution.



Virtual Memory Size: This option controls the size of the virtual memory 
swap file that the Reader program creates. If you cannot open a PDF file 
because the Reader program does not have enough memory, choose a set-
ting that increases the amount of virtual memory available to the Reader 
program.

Increasing the amount of virtual memory requires more free disk space. The 
amount of free disk space required depends on how much RAM you have 
and the number and kinds of Terminate and Stay Resident (TSR) programs 
you are using. The maximum amount of free disk space required when you 
have two megabytes (MB) of RAM and choose the large setting is seven 
MB. Increasing the virtual memory size increases the time it takes the 
Reader program to start.

By default, the virtual memory swap file is created on the disk drive where 
the Reader program is installed. See Changing the virtual memory swap file 
location to optimize performance

 

 for instructions on how to use another 
drive for the swap file.

A change in this setting does not take effect until you restart the Reader 
program.



Mouse double-click speed: This option lets you adjust the speed with 
which you must click the left mouse button for the Reader program to sense 
a double-click

 

 instead of two single clicks. If you find that the Reader 
program often interprets your double-click as two single clicks, choose 
a slower setting. If you find that the Reader program often interprets two 
single clicks as a double-click, choose a faster setting.

 

Mouse cursor color

 

: This option controls whether the mouse cursor is 
white or black. A black cursor is easier to see on some portable computer 
screens.

 

Video resolution

 

: This option lets you select the video resolution and 
number of colors that the Reader program uses to display PDF documents. 
Options not supported by your display adapter are dimmed and cannot be 
selected. Changes to this setting do not take effect until you restart the 
Reader program. See 

 

How the Reader program supports SVGA display 
adapters

 

 for more information about video resolution.



SEARCHING FOR WORDS
You can search for a word or part of a word in a document by using the Find 
feature.

To search for a word:

1 Click the find tool or choose Find from the Tools menu to open the 
Find dialog box. 

2 Select the Match Whole Word Only option if you want the Reader 
program to ignore words that contain the word you enter. Select the 
Match Case option if you want the program to find only those words 
that contain exactly the same capital and lowercase letters you enter in 
the Find dialog box.

3 Enter a single word or part of a word in the Find What text box, and 
click Find Next. When the program finds the word, the Find dialog box 
closes, the page containing the word is displayed, and the found word 
highlighted. 

4 To find the next occurrence of the word, press Control+G or reopen 
the Find dialog box and click Find Next.



USING NOTES
People who create or view Acrobat documents using the Acrobat Exchange

 

 

 

program

 

 can attach electronic notes to document pages. Acrobat notes rest 
on top of document pages and can be moved around the page. Notes can 
also be opened and closed: an open note appears as a text window; a closed 
note appears as a note icon. You can use the Create Notes File command in 
the Tools menu to display and print a PDF file with the text of all the notes 
in a document.

 

To open and close notes:

 

Double-click

 

 a note icon to open a note. Click the close box in the upper left 
corner of the note window to close a note.

 

To move a note:

 

If the note is closed, simply 

 

drag

 

 the note icon to the new position. If the 
note is open, drag the bar at the top of the note window. You cannot move 
a note to a different page.



To resize a note window:

Drag the lower right corner of an open note window down and to the right 
to make the note window larger. Drag the lower right corner of the note 
window up and to the left to make the window smaller. As you drag the 
lower right corner of the note window, an outline of a box shows the shape 
the note window will take when you release the mouse button.

To find notes:

Choose Next Note from the Tools menu to jump to the next page in the 
document that contains a note.

To view and print a PDF file with the text of all the notes in a 
document:

Choose Create Notes File from the Tools menu to create a PDF file with 
the text of all the notes in a document. The current document closes and the 
notes document appears in the window. The notes are listed in page-number 
order, starting with page one. When a page contains more than one note, 
the notes are numbered in the order they were created. You cannot save 
the notes file, but you can use the Print command in the File menu to print 
the notes.



USING LINKS
People who create Acrobat documents using the Acrobat Exchange program

 

 
can add link buttons to connect two parts of the document. You can then 
click the link buttons to jump to the related information. For example, the 
underlined text in this online guide represents link buttons that are linked 
to topics in the guide. 

Link buttons may or may not be enclosed in a box. When link buttons are 
not enclosed in a box, the text in the link button is usually formatted so that 
you can tell that it is a link button.

The Go Back button in the tool bar gives you a convenient way of returning 
from linked information. After reading the linked text, click the Go Back 
button as many times as necessary to return to the page containing the link 
button.



DISPLAYING INFORMATION ABOUT A DOCUMENT 
The Document Info command in the File menu displays a dialog box that 
contains information about a document. The information includes 

• The name and location of the PDF file

• The program that created the original document (if known)

• The application or driver that produced the PDF file

• The version of the Portable Document Format (PDF) used to represent the 
document

• The author of the document (if known)

• The date and time the PDF file was created

PDF document publishers can add information about a document to the 
Document Info dialog box. Typical additions include a document title and 
keywords that describe the contents of the document.



ABOUT FONTS
The DOS version of the Acrobat Reader program includes 16 Type 1 fonts

 

 
that are automatically installed with the program. Unless you change the 
default font directory when you install the Reader program, these fonts are 
placed in a \psfonts directory on your hard drive.

The Acrobat Reader Installer program copies the PFB files for the fonts 
to the \psfonts directory, and it copies the PFM files for the fonts to a 
\pfm directory within the \psfonts directory. PFB files contain the outlines 
for all the characters in a font. PFM files contain the font metrics for all 
the characters in a font. Font metrics describe relative character sizes.

When you view a PDF file that uses fonts that are not installed in the 
\psfonts directory, the Reader program must create 

 

substitute fonts

 

 to 
display on the screen. Similarly, when you print a document that uses 
unavailable fonts, the Reader program must create substitute fonts to 
print. When the Reader creates substitute fonts, documents take longer 
to display and to print.

You can speed printing and document display by installing the Type 1 fonts 
used in the PDF files you view. See 

 

Installing Type 1 fonts

 

 for instructions.



INSTALLING TYPE 1 FONTS
Most programs that install Type 1 fonts place the fonts in a \psfonts direc-
tory. By default, \psfonts is also the directory that the Reader program 
uses for Type 1 fonts. Every time the Reader program starts, it checks the 
\psfonts directory to see if new Type 1 fonts have been installed. If Type 1 
fonts have been installed in the \psfonts directory by other programs, the 
Reader program automatically uses them.

If you have already installed Type 1 fonts in the \psfonts directory before 
installing the Reader program, the Reader will automatically use those 
fonts. If you purchase Type 1 fonts after you install the Reader program and 
the installation software for those fonts installs the fonts in the \psfonts 
directory, the Reader program will automatically detect the new fonts and 
use them the next time you start the program.

If you are using the ATM  program for Windows, any fonts you install 
with ATM are automatically available to the Reader program (as long as 
ATM and the Reader are using the same font directory). If you purchase an 
Adobe Type package specifically for use with the Reader program, choose 
Other as the application when you install the fonts.



If you have installed Type 1 fonts into a directory other than \psfonts 
or other than the font directory you specified when you installed the Reader 
program, you must copy the PFB files for those fonts to the Reader font 
directory to use the fonts with the Reader. (The PFB files for a Type 1 font 
contain the outlines for all the characters in the font.) The Reader program 
does not require the PFM or AFM files for a Type 1 font to use the font. 
(PFM and AFM files for Type 1 fonts contain the metrics, or relative 
character sizes, for the characters in the fonts.)

If the Reader fails to notice a new font, or if it fails to notice that you deleted 
a font from the Reader’s font directory, choose Rebuild Font List from the 
Edit menu to instruct the Reader to rebuild its font list.



TYPE 1 FONTS INSTALLED WITH THE READER
The following Type 1 fonts are installed with the DOS version of the 
Acrobat Reader:

• Courier

• Courier bold

• Courier italic

• Courier bold italic

• Helvetica regular

• Helvetica bold

• Helvetica italic

• Helvetica italic bold

• Times regular

• Times bold

• Times italic

• Times italic bold

• Symbol

• Zapf Dingbats

• AdobeSerifMM

• AdobeSansXMM



AdobeSerifMM and AdobeSansXMM are multiple master fonts that the 
Reader program uses to create substitute fonts for fonts used in PDF docu-
ments that are not installed on your system. See How the Exchange and 
Reader programs display and print fonts

 

 and 

 

Choosing preferences

 

 for more 
information about these multiple master fonts.

See 

 

Installing Type 1 fonts

 

 for instructions on how to install additional Type 
1 fonts for use with the Reader program. See 

 

About fonts

 

 for general infor-
mation about how the Reader program uses fonts.



MENU COMMANDS 
The Acrobat Reader program commands are organized in six menus.

Click a menu name to see descriptions of the commands in that menu.

File menu

Edit menu

View menu

Tools menu

Window menu

Help menu



FILE MENU COMMANDS
Open (Ctrl+O) displays the Open File dialog box.

The Display File Types options include a PDF Files (*.pdf) option that 
limits files shown in the File list to files with the .PDF extension. 
PDF files created on a Macintosh might not have a .PDF extension. 
Choose the All Files (*.*) option to see all files in the current directory. 
See Opening documents

 

 for instructions on how to use the Open File 
dialog box.

 

Close

 

 (Ctrl+W) closes the document window of the current document.

You can also close a document by clicking the 

 

close box

 

 in the upper left 
corner of the document window.

 

Document Info

 

 (Ctrl+I) displays information about the current document. 
See 

 

Displaying information about a document

 

 for details.

 

Print 

 

(Ctrl+P) displays the Print dialog box with options for printing to a 
PostScript Level 2 printer and for shrinking (and possibly rotating) page 
images so that they fit the paper currently installed in the printer. 
See 

 

Printing documents

 

 for instructions on how to print documents.



Print Setup displays the Print Setup dialog box, which you use to set up 
the Reader program to work with your printer. See Setting up a printer

 

 for 
instructions.

 

1 FILENAME_1.PDF

 

 through 

 

4 FILENAME_4.PDF 

 

are the names of 
the last four files you opened. Click a filename to open the file.

 

Exit

 

 (Ctrl+Q) closes the document window, stops the Reader program, 
and returns you to the DOS prompt.



EDIT MENU COMMANDS
Rebuild Font List tells the Reader program to discard its current font list 
and create a new font list with all the Type 1 fonts in the Reader’s font 
directory. See About fonts

 

 for more information.

 

Preferences

 

 displays a dialog box in which you can select settings that 
affect all documents. See 

 

Choosing preferences

 

 for details.



VIEW MENU COMMANDS
For additional information about using View menu commands, see 
Magnifying the page view

 

 and 

 

Browsing through documents

 

.

 

Actual Size

 

 (Ctrl+H) displays the page at 100 percent. 

 

Fit Page to Window

 

 (Ctrl+J) scales the page so that the whole page is 
visible in the document area within the Reader window. 

 

Fit Width to Window

 

 (Ctrl+K) scales the page so that the width of the 
page fills the document area within the Reader window.

 

Zoom To

 

 (Ctrl+L) displays a dialog box in which you specify the percent-
age of magnification or reduction. You can reduce a page to 12 percent of 
its normal size and you can expand a page to 800 percent of its normal size.

 

First Page

 

 (Home) displays the first page of the document.

 

Previous Page

 

 (Up Arrow) displays the previous page of the document.

 

Next Page

 

 (Down Arrow) displays the next page of the document.



Last Page (End) displays the last page of the document.

Go to Page (Ctrl+A) displays a dialog box in which you specify the page 
you want to see.

Note: The page numbers used by the Reader program begin with page 1 for 
the first page of a document and continue sequentially through the last page 
of the document. For this reason, the Reader page numbers may not match 
the page numbers you see on document pages.

Go Back (Alt+-) retraces your path through a document, one screen 
(or view) at a time. You can retrace your steps through 100 views.

Go Forward (Alt+=) returns you to where you were before choosing 
Go Back.

Page Only closes the overview area of the Reader window.



Bookmarks and Page displays bookmarks in the overview area if book-
marks have been created for the document. Double-click the page icon 
to the left of a bookmark name to jump to the page view marked by that 
bookmark. See Using bookmarks

 

 for more information.

 

Thumbnails and Page

 

 displays thumbnail images of document pages in 
the overview area. If thumbnails have not been created for the document, pages 
in the overview area are represented as gray boxes. Click a thumbnail to jump 
to that page of the document. See 

 

Using thumbnails

 

 for more information.



TOOLS MENU COMMANDS
Hand turns the mouse pointer into the hand tool. To use the hand tool, hold 
down the mouse button and drag the page view in the direction you want it 
to scroll.

Zoom In turns the mouse pointer into the zoom-in tool. With the zoom-in 
tool selected, click the left mouse button to magnify the current view by a 
factor of two. See Magnifying the page view

 

 for more information.

 

Zoom Out

 

 turns the mouse pointer into the zoom-out tool. With the zoom-
out tool selected, click the left mouse button to reduce the current view by 
one half. See 

 

Magnifying the page view

 

 for more information.

 

Find

 

 (Ctrl+F) displays the Find dialog box, which you can use to find a 
word or part of a word in a document. See 

 

Searching for words

 

 for 
instructions.



Find Again (Ctrl+G) performs the same operation as the Find Next button 
in the Find dialog box: the next occurrence of the word is displayed.

Find Next Note (Ctrl+T) moves to the next page containing a note. The 
command does not display or open the note. 

Create Notes File displays a PDF file that contains the text of all the notes 
in a document. You can view and print the notes, but you cannot save the 
note file for later use. See Using notes

 

 for more information.



WINDOW MENU COMMAND
Hide/Show Tool Bar hides or displays the tool bar.



HELP MENU COMMANDS
Acrobat Reader Help opens this document.

About Acrobat Reader displays the startup screen for the Acrobat Reader 
program. Click anywhere to make the screen disappear.



TECHNICAL NOTES
This section contains topics that might be of interest to people providing 
technical support for the Acrobat Reader program. Click a topic name to see 
information about that topic.

• Using an unlisted printer

 

•

 

CONFIG.SYS and AUTOEXEC.BAT changes made by the Installer

 

•

 

Timeout requirements for network printers

 

•

 

How the Reader program supports SVGA display adapters

 

•

 

Changing the virtual memory swap file location to optimize performance

 

•

 

Displaying the version numbers of the Reader program components

 

•

 

Troubleshooting



USING AN UNLISTED PRINTER
If you do not see the model name of your printer in the list of printers in the 
Printer Setup dialog box, you may still be able to use your printer with the 
Reader program. 

Note: The Reader program does not work with 9-pin dot-matrix printers.

To use an unlisted printer with the Reader program:

In the Printer Model list, select the model name of a printer that your printer 
emulates. Many laser printers, for example, emulate printers from one of 
the HP  LaserJet  printer families. And many dot-matrix printers emulate 
the Epson  EPL series of printers. You might also try selecting another 
model made by the manufacturer of your printer.

If you cannot find a printer model on the Printer Model list that works with 
your printer, contact your printer’s manufacturer to find which, if any, 
printers your printer emulates.

Note: The Reader program works with color non-PostScript printers; 
however, with these printers, it prints only in black and white.



CONFIG.SYS AND AUTOEXEC.BAT CHANGES 
MADE BY THE READER PROGRAM INSTALLER
The Acrobat Reader program installer makes the following changes to the 
CONFIG.SYS and AUTOEXEC.BAT files. 

CONFIG.SYS command required to support the Reader

The CONFIG.SYS file must contain a FILES command that specifies 20 or 
more files. Here is an example FILES command:

 

FILES=20

AUTOEXEC.BAT command changed to support the Reader

If the AUTOEXEC.BAT file contains a PATH command that includes 
the Reader application directory, you can start the Acrobat Reader from any 
directory. By default, the Reader application directory is c:\acrodos. 
Here is an example PATH command with the default Reader application 
directory:

PATH c:\;c:\dos;c:\nu;c:\wp51;c:\acrodos



TIMEOUT REQUIREMENTS FOR NETWORK 
PRINTERS
If you are using a network printer, Adobe recommends that you (or your 
network administrator) set the timeout value for the printer to 30 seconds 
or more. With the Novell  Netware  Capture command, for example, you 
would set the timeout with TI=30, as shown below:

capture /l=1 /q=PrinterQueue /ti=30



HOW THE READER PROGRAM SUPPORTS SVGA 
DISPLAY ADAPTERS
The Acrobat Reader program supports the high-resolution and 256-color 
modes only for SVGA display adapters with video drivers that conform to 
the industry standard VESA specification. 

Note: The Reader program also supports the high-resolution and color 
modes of the 8514 display adapter.

Most display adapter manufacturers provide VESA-conforming drivers, 
even for their older adapters. Contact the dealer from whom you purchased 
your computer or the manufacturer of your display adapter for instructions 
on how you can obtain a VESA-conforming driver for your computer.

Display Adapter Terminology

VESA stands for Video Electronics Standards Association. VESA is an 
organization that defines standards for DOS video adapters with resolutions 
greater than the VGA standard.



VGA stands for Video Graphics Array. The VGA standard defines a 
display as an array of 640 by 480 pixels (dots) where each dot can be any 
of 16 colors.

SVGA stands for Super Video Graphics Array. The SVGA standard defines 
a display as an array of 800 by 600 pixels (dots) where each dot can be any 
of 256 colors.

8514 is the standard for recent IBM graphics adapters. The 8514 standard 
defines a maximum display resolution of 1,024 by 768 pixels (dots) where 
each dot can be any of 256 colors.



CHANGING THE VIRTUAL MEMORY SWAP FILE 
LOCATION TO OPTIMIZE PERFORMANCE
The DOS version of the Acrobat Reader program uses a virtual memory 
manager. By default, the swap file used by the memory manager is created 
as a temporary file on the drive where the Reader program is installed. 

Note: The virtual memory swap file is not related to the temporary files for 
which you specify a directory when the Reader program is installed.

The performance of the Reader program can suffer if the drive where the 
memory manager creates the swap file has limited free space. As a general 
rule, the more free space available for the swap file and the faster the drive 
used for the swap file, the better the Reader program performs.

You can change the default disk drive used for the swap file by changing a 
setting in the ACROBAT.VMC file. ACROBAT.VMC is an ASCII text file 
that is stored in the Reader program directory.



To change the location of the virtual memory swap file:

1 Using a text editor such as the DOS Edit program, or any word processor 
that can open and save ASCII text files, open the ACROBAT.VMC file in the 
Reader application directory. By default, the Reader application directory is 
c:\acrodos.

2 Find the line that looks like this:

swapname=c:\acrodos\acrobat.swp

3 Change the drive letter to the letter of the drive you want to use for the 
virtual memory swap file.

4 Save the ACROBAT.VMC file and quit the text editor or word processor. 
If you use a word processor, remember to save ACROBAT.VMC as an 
ASCII text file.



DISPLAYING THE VERSION NUMBERS OF THE 
READER PROGRAM COMPONENTS
The DOS version of the Acrobat Reader program is built with a number of 
software components. If you require the assistance of the Adobe Technical 
Support group, knowing the version numbers of these components might 
help the support person solve your problem.

To display the version numbers of the Reader components:

1 Choose About Acrobat Reader from the Help menu.

2 Click the Reader program version number in the lower left corner of the 
About box. The version number of the Reader program is displayed above the 
black bar.

3 Continue clicking the version number in the black bar. Each time you 
click, the name and version number of a Reader program component is 
displayed. After the version numbers of all the program components have 
been displayed, the names and sizes of memory regions used by the Reader 
program are displayed.



 

TROUBLESHOOTING

 

You can call Adobe Technical Support for help solving Acrobat-related 
problems. See SUPPORT.PDF in the Reader application directory for 
information about your technical support options. This topic describes the 
following problems:

• PDF files fail to open (see below)

• Cannot print to network printer

 

•

 

Graphics appear as gray boxes

 

•

 

Text appears as gray lines

 

•

 

Reader program quits unexpectedly

 

PDF files fail to open

 

The Reader program requires a large amount of virtual memory to open 
documents that contain complicated illustrations or that use many fonts. 
If you cannot open a document because the Reader program does not have 
enough virtual memory, use the Preferences dialog box to increase the 
size of the virtual memory swap file created by the Reader program. See 

 

Choosing Preferences

 

 for instructions.



Cannot print to network printer

If you cannot print to a network printer, you might not have specified the 
correct printer port in the Printer Setup dialog box. Make sure that the 
printer port you select in the Printer Setup dialog box is the printer port that 
is captured by your network software. Also, make sure that your network 
software is set up to correctly capture the port before you start the Reader 
program. See your network administrator if you suspect your network soft-
ware is not set up correctly.

Graphics appear as gray boxes

To speed page display, the Reader program can be set up to display “large” 
images as gray boxes. See Choosing preferences

 

 for a description of how to 
enable and disable this feature.

 

Text appears as gray lines

 

To speed page display, the Reader program can be set up to “greek” small 
characters. Greeked characters appear as gray lines. To read greeked char-
acters, zoom in on the part of the page containing the greeked characters. 
See 

 

Choosing preferences

 

 for a description of how to control this feature.



Reader program quits unexpectedly

If the Reader program quits unexpectedly, Adobe strongly recommends 
that you run the DOS CHKDSK program for the drive where the Reader 
program is installed. If you have changed the default drive for the virtual 
memory swap file, you should run the CHKDSK program for that drive 
too. See your DOS documentation for a description of the CHKDSK 
program.
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KEYBOARD SHORTCUTS

Tool or key Plus Result

Esc key Interrupts display of page; 
also cancels a dialog box

Zoom-in Ctrl Zoom-out

Zoom-out Ctrl Zoom-in

F1 Opens online guide

Home Displays first page of document

End Displays last page of document

Page Down/Enter Moves forward one screenful

Page Up/Shift+Enter Moves backward one screenful

Right/Down Arrow Displays next page

Left/Up Arrow Displays previous page
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